Follow this Blog!

Jul 22, 2013

f Comment

[SOLVED] Install PHP Curl On Amazon EC2 Ubuntu in SECONDS!

Amazon If you are running Ubuntu on an Amazon EC2 instance and you are running a PHP website, you may come across the following error when you include a third party library such as Facebook PHP SDK.

Error: facebook.php needs PHP Curl plugin.
The problem is simple. Your PHP engine needs to have the curl plugin enabled because facebook SDK uses curl. Read on to see how this can be done within seconds.

My ubuntu is Ubuntu 10.04.4 LTS
Solution
Run the following command to install PHP5 curl plugin.

sudo apt-get install php5-curl
Once you have the curl module installed it is enabled automatically when you restart the PHP CGI gateway. Therefore run the next command.

sudo /etc/init.d/php-fastcgi restart
Now you've successfully installed the curl php library and enabled it in your PHP engine.

That's it! I told you it'd only take seconds didn't I?

If you have any questions let me know and I will do my best to help you!
Please leave a comment here!
One Minute Information - by Michael Wen
Find Michael on Google or Facebook
ADVERTISING WITH US - Direct your advertising requests to Michael