Follow this Blog!

May 4, 2015

f Comment

Fixing Eclipse SVN error: Location information has been specified incorrectly

Amazon When trying to check out an SVN source controlled project into Eclipse, I got this "Validate Location" Windows dialog showing this error message:

Location information has been specified incorrectly.
svn: Number is larger than maximum
Keep location anyway?

A solution is posted on but I have found another solution which is simpler. Read on to see what it is.

My Unix version: Ubuntu 14.04.1 LTS (GNU/Linux 3.13.0-43-generic x86_64)
My SVN version: 1.8.8 (r1568071)
My Eclipse version: Eclipse for PHP Developers 3.0.2


Here is how I fixed this "Validate Location" error:

1. Go to Window -> Preferences -> Team -> SVN.

2. Select "SVN Connector" tab

3. Select "Native JavaHL 1.6.15 r1038135 (SVN 1.6.15)" instead of "SVNKit 1.3.8 r9269 (SVN 1.6.18 compatible, all platforms)".

Then check out the project again and this error will go away. However, you will no longer be able to use svn+ssh. The repository URL would be something like this:

svn://username@<your server's IP address>/svnrepos/repository

Questions? Let me know!
Please leave a comment here!
One Minute Information - by Michael Wen
Find Michael on Google or Facebook
ADVERTISING WITH US - Direct your advertising requests to Michael